import Foundation
let pattern = #"^(?:([^,\n]*),){3}([^\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
null,admin,abc@site.ru,123
null,admin,cde@site.ru,345
,joe,efg@site.ru,333
,bob,ghj@site.ru,444
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1:$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)