using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[+[\u0A00-\u0A7F]+\\\w+]]\w+";
string input = @"[[ਅਤੇ\CC_CCD]]_CCP
[[ਅਤੇ\CC_CCD]]_CCP [[ਵਿਚ\PSP]]_BLK";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}