$re = '/\[+[\u0A00-\u0A7F]+\\\\\w+]]\w+/m';
$str = '[[ਅਤੇ\\CC_CCD]]_CCP
[[ਅਤੇ\\CC_CCD]]_CCP [[ਵਿਚ\\PSP]]_BLK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);