re = /\[+[\u0A00-\u0A7F]+\\\w+]]\w+/m
str = '[[ਅਤੇ\\CC_CCD]]_CCP
[[ਅਤੇ\\CC_CCD]]_CCP [[ਵਿਚ\\PSP]]_BLK'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end