// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[+[\u0A00-\u0A7F]+\\\w+]]\w+").unwrap();
let string = "[[ਅਤੇ\\CC_CCD]]_CCP
[[ਅਤੇ\\CC_CCD]]_CCP [[ਵਿਚ\\PSP]]_BLK";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}