import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[+[\\u0A00-\\u0A7F]+\\\\\\w+]]\\w+";
final String string = "[[ਅਤੇ\\CC_CCD]]_CCP\n\n"
+ "[[ਅਤੇ\\CC_CCD]]_CCP [[ਵਿਚ\\PSP]]_BLK";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}