#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?si).*Invoice[\s_:.]+(?<anr>[^\s_]+).+"
Local $sString = "Payer:_xxxxxxx" & @CRLF & _
"Waybill Invoice_IN280625-3/4 Nimetus_EAN " & @CRLF & _
"Invoice issuer: John" & @CRLF & _
"Selle Invoice tasumisel palume m lisada Kesolev Invoice on poolte" & @CRLF & _
"vahel Invoice mittetähtaegsel tasumisel on müüjal õigus nõuda viivist 0,1% tasumata summalt päevas." & @CRLF & _
"Kuni Invoice payment sumiseni k" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")