package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?si).*Invoice[\s_:.]+(?<anr>[^\s_]+).+`)
var str = `Payer:_xxxxxxx
Waybill Invoice_IN280625-3/4 Nimetus_EAN
Invoice issuer: John
Selle Invoice tasumisel palume m lisada Kesolev Invoice on poolte
vahel Invoice mittetähtaegsel tasumisel on müüjal õigus nõuda viivist 0,1% tasumata summalt päevas.
Kuni Invoice payment sumiseni k
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}