import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?si).*Invoice[\\s_:.]+(?<anr>[^\\s_]+).+";
final String string = "Payer:_xxxxxxx\n"
+ "Waybill Invoice_IN280625-3/4 Nimetus_EAN \n"
+ "Invoice issuer: John\n"
+ "Selle Invoice tasumisel palume m lisada Kesolev Invoice on poolte\n"
+ "vahel Invoice mittetähtaegsel tasumisel on müüjal õigus nõuda viivist 0,1% tasumata summalt päevas.\n"
+ "Kuni Invoice payment sumiseni k\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}