# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?si).*Invoice[\s_:.]+(?<anr>[^\s_]+).+"
test_str = ("Payer:_xxxxxxx\n"
"Waybill Invoice_IN280625-3/4 Nimetus_EAN \n"
"Invoice issuer: John\n"
"Selle Invoice tasumisel palume m lisada Kesolev Invoice on poolte\n"
"vahel Invoice mittetähtaegsel tasumisel on müüjal õigus nõuda viivist 0,1% tasumata summalt päevas.\n"
"Kuni Invoice payment sumiseni k\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.