using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s*میلیون";
string input = @"منزل۲۲۰ متری دونبش کلنگی ۲۰ سال ساخت سند شش دانگ واقع در چهارراه دولت آباد قیمت ۲۸۰ میلیون تومان";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}