$re = '/(\d+)\s*میلیون/m';
$str = 'منزل۲۲۰ متری دونبش کلنگی ۲۰ سال ساخت سند شش دانگ واقع در چهارراه دولت آباد قیمت ۲۸۰ میلیون تومان';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);