// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)\s*میلیون").unwrap();
let string = "منزل۲۲۰ متری دونبش کلنگی ۲۰ سال ساخت سند شش دانگ واقع در چهارراه دولت آباد قیمت ۲۸۰ میلیون تومان";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}