re = /(\d+)\s*میلیون/m
str = 'منزل۲۲۰ متری دونبش کلنگی ۲۰ سال ساخت سند شش دانگ واقع در چهارراه دولت آباد قیمت ۲۸۰ میلیون تومان'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end