using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<!\b[01][0-9])(?<!\b[2][0-3])([^\S\r\n]*:)[^\S\r\n]*(?![0-5][0-9](?:[ap]\.?m\b\.?)?)";
string substitution = @"\1\n";
string input = @"am
pm
P.M.
10:56pm : start a new line
10:43 a.m.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}