const regex = new RegExp('(?i)(?<!\\b[01][0-9])(?<!\\b[2][0-3])([^\\S\\r\\n]*:)[^\\S\\r\\n]*(?![0-5][0-9](?:[ap]\\.?m\\b\\.?)?)', 'g')
const str = `am
pm
P.M.
10:56pm : start a new line
10:43 a.m.`;
const subst = `\1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);