const regex = /([A-Z0-9])(?:([A-Z0-9\.\-\s]*)*\:+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z0-9])(?:([A-Z0-9\\.\\-\\s]*)*\\:+)', 'gm')
const str = `MR. SMITH:
- CAPTAIN AMERICA:
ANT-MAN:
2014 NEBULA:
-2012 IRON MAN:
BOY 1:
1
00:00:07,174 --> 00:00:09,837
BARTON: Okay, hold on.
16
00:00:36,411 --> 00:00:37,527
- COOPER: Nice!
- LAURA: Nice throw, kiddo.
`;
const subst = `\<font color\=\"\#FFA500\"\>\<b\>$0\<\/b\>\<\/font\>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);