use strict;
my $str = 'MR. SMITH:
- CAPTAIN AMERICA:
ANT-MAN:
2014 NEBULA:
-2012 IRON MAN:
BOY 1:
1
00:00:07,174 --> 00:00:09,837
BARTON: Okay, hold on.
16
00:00:36,411 --> 00:00:37,527
- COOPER: Nice!
- LAURA: Nice throw, kiddo.
';
my $regex = qr/([A-Z0-9])(?:([A-Z0-9\.\-\s]*)*\:+)/mp;
my $subst = '\\<font color\\=\\"\\#FFA500\\"\\>\\<b\\>$0\\<\\/b\\>\\<\\/font\\>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";