// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z0-9])(?:([A-Z0-9\.\-\s]*)*\:+)").unwrap();
let string = "MR. SMITH:
- CAPTAIN AMERICA:
ANT-MAN:
2014 NEBULA:
-2012 IRON MAN:
BOY 1:
1
00:00:07,174 --> 00:00:09,837
BARTON: Okay, hold on.
16
00:00:36,411 --> 00:00:37,527
- COOPER: Nice!
- LAURA: Nice throw, kiddo.
";
let substitution = "\\<font color\\=\\\"\\#FFA500\\\"\\>\\<b\\>$0\\<\\/b\\>\\<\\/font\\>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}