import Foundation
let pattern = #"([A-Z0-9])(?:([A-Z0-9\.\-\s]*)*\:+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MR. SMITH:
- CAPTAIN AMERICA:
ANT-MAN:
2014 NEBULA:
-2012 IRON MAN:
BOY 1:
1
00:00:07,174 --> 00:00:09,837
BARTON: Okay, hold on.
16
00:00:36,411 --> 00:00:37,527
- COOPER: Nice!
- LAURA: Nice throw, kiddo.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"\<font color\=\"\#FFA500\"\>\<b\>$0\<\/b\>\<\/font\>"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)