const regex = /<a.*?href=("|')(.*?)("|').*?>(.*?)<\/a>\s(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.*?href=("|\')(.*?)("|\').*?>(.*?)<\\\/a>\\s(.*)', 'gm')
const str = `<a href="https://www.catholicgallery.org/bible-drb/acts-9/">Acts 9:</a> 1-20
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}