$re = '/<a.*?href=("|\')(.*?)("|\').*?>(.*?)<\/a>\s(.*)/m';
$str = '<a href="https://www.catholicgallery.org/bible-drb/acts-9/">Acts 9:</a> 1-20
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);