using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^project\(\n\s+[^\n]+\n\s+version:\s+'([^']+)',\n";
string input = @"project(
'waybar', 'cpp', 'c',
version: '0.9.20',
license: 'MIT',
meson_version: '>= 0.50.0',
default_options : [
'cpp_std=c++20',
'buildtype=release',
'default_library=static'
],
)";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}