re = /^project\(\n\s+[^\n]+\n\s+version:\s+'([^']+)',\n/
str = 'project(
\'waybar\', \'cpp\', \'c\',
version: \'0.9.20\',
license: \'MIT\',
meson_version: \'>= 0.50.0\',
default_options : [
\'cpp_std=c++20\',
\'buildtype=release\',
\'default_library=static\'
],
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end