// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)^project\(\n\s+[^\n]+\n\s+version:\s+'([^']+)',\n").unwrap();
let string = "project(
'waybar', 'cpp', 'c',
version: '0.9.20',
license: 'MIT',
meson_version: '>= 0.50.0',
default_options : [
'cpp_std=c++20',
'buildtype=release',
'default_library=static'
],
)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}