use strict;
my $str = 'project(
\'waybar\', \'cpp\', \'c\',
version: \'0.9.20\',
license: \'MIT\',
meson_version: \'>= 0.50.0\',
default_options : [
\'cpp_std=c++20\',
\'buildtype=release\',
\'default_library=static\'
],
)';
my $regex = qr/^project\(\n\s+[^\n]+\n\s+version:\s+'([^']+)',\n/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}