using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\^{[a-zA-Z]*})}";
string substitution = @"\1";
string input = @"lore ipsum ^{someWord}} lore ipsum";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}