$re = '/(\^{[a-zA-Z]*})}/m';
$str = 'lore ipsum ^{someWord}} lore ipsum';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;