package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\^{[a-zA-Z]*})}`)
var str = `lore ipsum ^{someWord}} lore ipsum`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}