import re
regex = re.compile(r"(\^{[a-zA-Z]*})}", flags=re.MULTILINE)
test_str = "lore ipsum ^{someWord}} lore ipsum"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)