use strict;
my $str = 'lore ipsum ^{someWord}} lore ipsum';
my $regex = qr/(\^{[a-zA-Z]*})}/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";