# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S+) (North East)/\2 \1/gm;t' <<< "North East Isle
London Northwestern
North East Bedfordshire
Southward and North East Bermondsey
Middlesbrough South and Cleveland East"