package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+) (North East)`)
var str = `North East Isle
London Northwestern
North East Bedfordshire
Southward and North East Bermondsey
Middlesbrough South and Cleveland East`
var substitution = "\2 \1"
fmt.Println(re.ReplaceAllString(str, substitution))
}