$re = '/(\S+) (North East)/m';
$str = 'North East Isle
London Northwestern
North East Bedfordshire
Southward and North East Bermondsey
Middlesbrough South and Cleveland East';
$subst = "\2 \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;