import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+) (North East)";
final String string = "North East Isle\n"
+ "London Northwestern\n"
+ "North East Bedfordshire\n"
+ "Southward and North East Bermondsey\n"
+ "Middlesbrough South and Cleveland East";
final String subst = "\\2 \\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}