import Foundation
let pattern = #"(\S+) (North East)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
North East Isle
London Northwestern
North East Bedfordshire
Southward and North East Bermondsey
Middlesbrough South and Cleveland East
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2 \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)