#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(?:\d*[A-Za-z]))(?=(?:\S*?[A-Z]){3,}\S*?$)(?=(?:[a-zA-Z]*\d))[A-Za-z0-9]{5,30}"
Local $sString = "Detect" & @CRLF & _
"" & @CRLF & _
"https://stackoverflow.com/%22Abcde3FGhiDE%22Zyx23" & @CRLF & _
"|a|b|c|AbcdEFGH123|456Ac" & @CRLF & _
"P A Abcde3Dd3FGhiDE Z H" & @CRLF & _
"ZZ123!Abcde3FGhiDE!123" & @CRLF & _
"" & @CRLF & _
"Don't detect" & @CRLF & _
"" & @CRLF & _
"IAMoverTHELIMITTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT3" & @CRLF & _
"NULLLLLLLLLLLLLLLLLLLLLLllll" & @CRLF & _
"|A|b|c|D|E|F|1|" & @CRLF & _
"<HeLLoWoRlD"123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")