$re = '/(?=(?:\d*[A-Za-z]))(?=(?:\S*?[A-Z]){3,}\S*?$)(?=(?:[a-zA-Z]*\d))[A-Za-z0-9]{5,30}/m';
$str = 'Detect
https://stackoverflow.com/%22Abcde3FGhiDE%22Zyx23
|a|b|c|AbcdEFGH123|456Ac
P A Abcde3Dd3FGhiDE Z H
ZZ123!Abcde3FGhiDE!123
Don\'t detect
IAMoverTHELIMITTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT3
NULLLLLLLLLLLLLLLLLLLLLLllll
|A|b|c|D|E|F|1|
<HeLLoWoRlD"123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);