const regex = /(?=(?:\d*[A-Za-z]))(?=(?:\S*?[A-Z]){3,}\S*?$)(?=(?:[a-zA-Z]*\d))[A-Za-z0-9]{5,30}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?:\\d*[A-Za-z]))(?=(?:\\S*?[A-Z]){3,}\\S*?$)(?=(?:[a-zA-Z]*\\d))[A-Za-z0-9]{5,30}', 'gm')
const str = `Detect
https://stackoverflow.com/%22Abcde3FGhiDE%22Zyx23
|a|b|c|AbcdEFGH123|456Ac
P A Abcde3Dd3FGhiDE Z H
ZZ123!Abcde3FGhiDE!123
Don't detect
IAMoverTHELIMITTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT3
NULLLLLLLLLLLLLLLLLLLLLLllll
|A|b|c|D|E|F|1|
<HeLLoWoRlD"123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}