using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:\d*[A-Za-z]))(?=(?:\S*?[A-Z]){3,}\S*?$)(?=(?:[a-zA-Z]*\d))[A-Za-z0-9]{5,30}";
string input = @"Detect
https://stackoverflow.com/%22Abcde3FGhiDE%22Zyx23
|a|b|c|AbcdEFGH123|456Ac
P A Abcde3Dd3FGhiDE Z H
ZZ123!Abcde3FGhiDE!123
Don't detect
IAMoverTHELIMITTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT3
NULLLLLLLLLLLLLLLLLLLLLLllll
|A|b|c|D|E|F|1|
<HeLLoWoRlD""123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}