#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-z])(?=.*[A-Z])(?=.*\d).{6,15}$"
Local $sString = "aA2222" & @CRLF & _
"Aa2222" & @CRLF & _
"fdsafdskj2" & @CRLF & _
"fdsjkl22" & @CRLF & _
"" & @CRLF & _
"Afdjskl12fsdafdsjhjk" & @CRLF & _
"fdsjlkA34l"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")