using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-z])(?=.*[A-Z])(?=.*\d).{6,15}$";
string input = @"aA2222
Aa2222
fdsafdskj2
fdsjkl22
Afdjskl12fsdafdsjhjk
fdsjlkA34l";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}