re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d).{6,15}$/m
str = 'aA2222
Aa2222
fdsafdskj2
fdsjkl22
Afdjskl12fsdafdsjhjk
fdsjlkA34l'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end