import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[a-z])(?=.*[A-Z])(?=.*\\d).{6,15}$";
final String string = "aA2222\n"
+ "Aa2222\n"
+ "fdsafdskj2\n"
+ "fdsjkl22\n\n"
+ "Afdjskl12fsdafdsjhjk\n"
+ "fdsjlkA34l";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}