$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*\d).{6,15}$/m';
$str = 'aA2222
Aa2222
fdsafdskj2
fdsjkl22
Afdjskl12fsdafdsjhjk
fdsjlkA34l';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);