#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "R\$:[\t ]*((\d{1,3}\.?)+(,\d{2})?)"
Local $sString = "- João da Silva número 123456 com o valor de R$:6.298,65" & @CRLF & _
"- João da Silva número 123456 com o valor de R$:6.298,65" & @CRLF & _
"- João da Silva número 123456 com o valor de R$:298,65" & @CRLF & _
"- João da Silva número 123456 com o valor de R$:98,65" & @CRLF & _
"- João da Silva número 123456 com o valor de R$:8,65" & @CRLF & _
"- João da Silva número 123456 com o valor de R$:26.298,65" & @CRLF & _
"- João da Silva número 123456 com o valor de R$:726.298,65" & @CRLF & _
"- João da Silva número 123456 com o valor de R$:8.726.298,65" & @CRLF & _
"- João da Silva número 123456 com o valor de R$:8.726.298" & @CRLF & _
"- João da Silva número 123456 com o valor de R$:26.298"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")