using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"R\$:[\t ]*((\d{1,3}\.?)+(,\d{2})?)";
string input = @"- João da Silva número 123456 com o valor de R$:6.298,65
- João da Silva número 123456 com o valor de R$:6.298,65
- João da Silva número 123456 com o valor de R$:298,65
- João da Silva número 123456 com o valor de R$:98,65
- João da Silva número 123456 com o valor de R$:8,65
- João da Silva número 123456 com o valor de R$:26.298,65
- João da Silva número 123456 com o valor de R$:726.298,65
- João da Silva número 123456 com o valor de R$:8.726.298,65
- João da Silva número 123456 com o valor de R$:8.726.298
- João da Silva número 123456 com o valor de R$:26.298";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}