# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"R\$:[\t ]*((\d{1,3}\.?)+(,\d{2})?)"
test_str = ("- João da Silva número 123456 com o valor de R$:6.298,65\n"
"- João da Silva número 123456 com o valor de R$:6.298,65\n"
"- João da Silva número 123456 com o valor de R$:298,65\n"
"- João da Silva número 123456 com o valor de R$:98,65\n"
"- João da Silva número 123456 com o valor de R$:8,65\n"
"- João da Silva número 123456 com o valor de R$:26.298,65\n"
"- João da Silva número 123456 com o valor de R$:726.298,65\n"
"- João da Silva número 123456 com o valor de R$:8.726.298,65\n"
"- João da Silva número 123456 com o valor de R$:8.726.298\n"
"- João da Silva número 123456 com o valor de R$:26.298")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.