import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "R\\$:[\\t ]*((\\d{1,3}\\.?)+(,\\d{2})?)";
final String string = "- João da Silva número 123456 com o valor de R$:6.298,65\n"
+ "- João da Silva número 123456 com o valor de R$:6.298,65\n"
+ "- João da Silva número 123456 com o valor de R$:298,65\n"
+ "- João da Silva número 123456 com o valor de R$:98,65\n"
+ "- João da Silva número 123456 com o valor de R$:8,65\n"
+ "- João da Silva número 123456 com o valor de R$:26.298,65\n"
+ "- João da Silva número 123456 com o valor de R$:726.298,65\n"
+ "- João da Silva número 123456 com o valor de R$:8.726.298,65\n"
+ "- João da Silva número 123456 com o valor de R$:8.726.298\n"
+ "- João da Silva número 123456 com o valor de R$:26.298";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}