import Foundation
let pattern = #"R\$:[\t ]*((\d{1,3}\.?)+(,\d{2})?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
- João da Silva número 123456 com o valor de R$:6.298,65
- João da Silva número 123456 com o valor de R$:6.298,65
- João da Silva número 123456 com o valor de R$:298,65
- João da Silva número 123456 com o valor de R$:98,65
- João da Silva número 123456 com o valor de R$:8,65
- João da Silva número 123456 com o valor de R$:26.298,65
- João da Silva número 123456 com o valor de R$:726.298,65
- João da Silva número 123456 com o valor de R$:8.726.298,65
- João da Silva número 123456 com o valor de R$:8.726.298
- João da Silva número 123456 com o valor de R$:26.298
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)